Make a Wireless Peer-to-Peer Connection

By Ronald Pacchiano | Posted May 27, 2005

I'm trying to set up peer-to-peer wireless network between two desktop computers. One is running Windows XP Home Edition and is equipped with a NetGear PCI wireless card. The other is running Windows XP Media Center with a D-Link USB wireless adapter. Both cards look like they're configured correctly and are coming up as working in Device Manager, but they can't seem to communicate with each other. Although an icon in the status bar says I'm connected, I can't ping from one machine to the other. Any suggestions you have would be greatly appreciated.

Before we continue, I just want to point out that in spite of the fact that the status bar says you're connected, there is a good possibility that your network isn't configured correctly. All this indicator really implies is that the card can see the presence of another wireless adapter or access point. It doesn't mean that it can communicate with it.

Now with that being said, you didn't provide enough details on your network configuration to allow me to tell you exactly what might be causing the problem. However, there are a number of things you can check that should help resolve it. You didn't mention if these systems had access to the Internet, so any of the suggestions I make might have to be modified a bit to keep your Internet connection up and running. Use the following information as a guideline only.


First things first: check the basics. Make sure that both computers are members of the same workgroup. Next you'll need to double-check your IP settings. In a Peer-to-Peer environment (or one without an access point) you should make sure that both PCs are using a static IP address and share a common subnet mask. A typical example would be to give PC number one an IP address of 192.168.0.2 and PC number two an IP address of 192.168.0.3. The 192.168.0.1 address is usually reserved for the router/gateway address. Then each PC would be given a Subnet mask of 255.255.255.0.

With that done, we now need to take a look at your wireless settings. Since you're not using an access point, check and make sure both wireless network cards are in ad-hoc mode rather than infrastructure mode. Most cards default to infrastructure mode, so this is a common problem.

Next verify that both wireless cards are configured to use the same wireless settings. They should share a common SSID (just like the workgroup name) and they should be transmitting data on the same channel. Adapters made by different vendors sometimes default to different channels, which would prevent communication.

You should also disable all levels of encryption for the time being. While I understand that you want your data to be secure, both WEP and WPA encryption can be extremely problematic to configure, particularly from cards made by different vendors. Once you have connectivity between your two systems, you can worry about getting the security encryption to function properly.

When you do finally enable it, take your time and ensure that the security settings on both cards are set to the same encryption type (WEP/WPA), level (64-bit, 128-bit and so on) and are using identical encryption keys. If you follow these steps carefully, you should find yourself online in no time. Good Luck!

Over the years I've had a couple of different printers. Each time I added one, I ended up having to add a new TCP LPR port to my system. Since I don't use (or even have) most of those old printers anymore, I thought that I would just delete those unneeded ports from my system. However, when I attempt to remove them I get an error message that says that the resource is in use and cannot be removed. Most of these printers aren't even connected to the PC anymore, so I don't understand how the port could possibly be in use. Do you have any idea how to go about removing these TCP ports from my system? Thanks.

In order to change or remove a port from the system, it has to be unallocated. When you first created the port it was assigned to a specific printer. Even though that printer might not be physically connected to the PC, the port is still being allocated to it. This is why the system tells you that the resource is in use and cannot be removed. In order to remove it, all you need to do is delete the printer that it was originally created for. If you used that port for any additional printers, those will need to be deleted as well.

Now that the printer(s) have been deleted, you need to delete the unused port. To do this, go into the properties of any printer installed on your system and proceed to the Ports tab. FYI: Make a note of the port currently assigned to this printer so you can put it back later. Now highlight the port you wish to remove from your system and press the "Delete Port" button. The system will ask you if you're sure you want to remove this port. Answer yes. Repeat this process for all of the ports you want to remove. When finished deleting the last one, set the port back to the one that you made note of earlier and press "Close." If you forget to do this, the printer won't work anymore. I hope that helps.

Adapted from PracticallyNetworked.com, part of the EarthWeb.com Network.

Do you have a comment or question about this article or other small business topics in general? Speak out in the SmallBusinessComputing.com Forums. Join the discussion today!

Comment and Contribute


     

    Get free tips, news and advice on how to make technology work harder for your business.

    Submit
    Learn more
     
    You have successfuly registered to
    Enterprise Apps Daily Newsletter
    • webcast video
      Microsoft Publisher Tips This video shows you how to create great-looking business brochures with Microsoft Publisher 2003.
    • webcast video
      Photoshop Tips In this video, we show you how to improve on or eliminate ugly and unwanted backgrounds.