Is XP to Blame for Drops in Wireless Connection?

By Ronald Pacchiano | Posted May 20, 2005

Not to long ago I purchased an older Dell Latitude laptop computer on eBay. The unit arrived in perfect condition and with Windows 98 installed on it. Since it had enough memory — and this being the year 2005 — I decided that I would upgrade the system to Windows XP. The upgrade went fine and, until recently, the system had never given me any problems. However, that all changed the day I upgraded it with a Netgear wireless network adapter. Now whenever I'm using the wireless network adapter for connectivity, the connection seems to drop every few minutes. It reconnects shortly after, but it is extremely annoying.

During my troubleshooting I discovered that when I disable the wireless adapter and connect the system back to the network using the RJ-45 Ethernet port it runs flawlessly. So it seems to me that this is a problem with the wireless adapter. I double-checked all of the configuration settings, but everything looks like it's OK to me. So I was wondering if you had any idea what might be causing this condition and what I could possibly do to correct it. Thanks!

I've seen this happen before and you're right, it is extremely annoying. If this is the same problem I've run across in the past, I'd be willing to bet money that you're running Windows XP Service Pack 1. The Internet connection dropping repeatedly was a known problem that I believe was corrected with the release of Service Pack 2, which you can download and install using the Windows Update site. SP2 addressed a problem with Windows XP's Wireless Zero Configuration service.


For those of you not familiar with it, the Wireless Zero Configuration (WZC) service is not a third-party application, but rather a service built into the Windows XP operating system. The WZC service is designed to dynamically select the wireless network to connect to, based either on your preferences or on the default settings. This includes automatically selecting and connecting to a more preferred wireless network when one becomes available. This feature lets you easily move from your office or home network without first having to reconfigure your IP settings before you can get online.

The problem addressed by SP2 had to do with the fact that in SP1 the WZC service was, by default, configured to use 802.1 x authentications. This authentication process caused the system to drop the wireless connection about every three to five minutes. To avoid this problem 802.1x authentication must be disabled.

If for some reason you'd rather not upgrade to SP2 (which is entirely reasonable), you can still correct this condition, but you'll need to do it manually. To disable 802.1x Authentication in Windows XP just perform the following steps:

  1. Click Start, point to Connect To, Click Show all connections, and then double-click your wireless network
  2. On the General tab, click Properties
  3. Click the Wireless Networks tab
  4. Under Preferred Networks, click your home network and then click Properties
  5. Click the Authentication tab, and then clear the Enable IEEE 802.1x authentication for this network check box

That should do it. I'm 95 percent confident that this will correct your issue. If not, the only other suggestion I have is to first make sure that you're not using a third-party firewall or spyware application that might inadvertently block that connection. Also, double-check your router settings. Your ISP might be using PPPoE or possibly another service requiring a login.

Most routers have a default timeout of five minutes when using PPPoE. This means that after five minutes of inactivity, the Internet connection will be dropped. The next time an Internet request is made, the connection automatically reinitializes. If the reconnection process experiences some latency (like your ISP is experiencing high traffic conditions), then you might run into connection problems. To help compensate for this problem, set the timeout to a higher value or to zero, which would prevent the router from ever logging out. Consult your router manuals for instructions.

Also, I always tell people that many PC problems can be corrected just by doing a simple reboot. This applies to your network as well. Try to restart all of your network devices in this order:

  • Power off your computer.
  • Power off your router.
  • Power off your modem.
  • Power on your modem. Wait until modem is completely restarted before the next step. This may take a few minutes to complete.
  • Power on your router. Wait until router completely restarts. This might also take a minute or two.
  • Lastly, power on your computer.

This should help speed up and stabilize the network a bit and, at the very least, it won't hurt anything. I hope this helps. Good luck!

Adapted from PracticallyNetworked.com, part of the EarthWeb.com Network.

Do you have a comment or question about this article or other small business topics in general? Speak out in the SmallBusinessComputing.com Forums. Join the discussion today!

Comment and Contribute


     

    Get free tips, news and advice on how to make technology work harder for your business.

    Submit
    Learn more
     
    You have successfuly registered to
    Enterprise Apps Daily Newsletter
    • webcast video
      Microsoft Publisher Tips This video shows you how to create great-looking business brochures with Microsoft Publisher 2003.
    • webcast video
      Photoshop Tips In this video, we show you how to improve on or eliminate ugly and unwanted backgrounds.