Yes, Your Work PC Can Go Home Again

By Ronald Pacchiano | Posted June 03, 2004
I just brought home an old PC from my office and tried attaching it to my router for Internet access. Upon boot up, the PC successfully received an IP address and can see the other computers in the workgroup. However, for some unknown reason, I can't seem to get this machine to browse the Web. No matter what site I visit, I always get a message indicating that the page is not available. I don't understand what could be causing this. The system worked fine in my office, and all of my other PCs have no trouble getting online.

The thing that really has me stumped is that while I can't browse the Internet, I can perform other online tasks. For example, I can download e-mail to my Eudora Mail and I can even connect to my MIRC chat. What's even more baffling is the fact that I can still Ping sites on the Internet, but not surf them.

Situations like this can be pretty frustrating, but I'd be willing to bet money that I know what your problem is. Let's take it one step at a time.

You indicated that the PC worked fine in your office and that when it was installed onto your home network it still allowed you to perform a few online tasks like downloading e-mail, pinging Web addresses and accessing online applications like MIRC. This tells us that TCP/IP is correctly configured on this PC, which immediately rules that out as a problem. You go on to say that all of your other PCs can browse the Web just fine, so obviously there isn't a problem with your router or Internet connection.

So what have we learned? We learned that the problem is isolated to this Micron PC — specifically with Internet Explorer itself. So it's logical to assume that the answer to the problem will be found in Internet Explorer as well. So taking all of that into account, if I had to hazard a guess as to what the problem is, I would say that all of the PCs on your office network are configured to use a Proxy server.

Many companies use Proxy servers to regulate what sites employees can and can't reach, preventing their employees from accessing inappropriate material (or simple goofing off) while in the office. Proxy servers are physically located between the user's PC and the company's Internet gateway. In addition to regulating Internet content, they can also be used for security purposes (similar to a firewall) or to speed up browsing by caching frequently visited Web pages. Since this was originally an office system, it could very well have been configured in this manner.

Now that it has been removed from that environment, it no longer works because it's still searching for the proxy server to tell it what to do. However, this situation can be easily corrected. Here's how:

Just launch Internet Explorer and select Tools, then Internet Options and then the Connections tab. Click the LAN settings button toward the bottom of the window. You'll probably find a check mark in the box labeled Use a Proxy Server for your LAN. Clear it, close Internet Explorer and relaunch it. You should now have access to the Web. I hope this worked for you.


I recently purchased a new laptop computer and it came with Windows XP Home Edition preinstalled. I use this machine primarily at work to access our Windows 2000 network server. Most of our data is stored on the network and, as a result, I've had to map a number of the network drives to my system. My previous notebook was using Windows 98 Second Edition and it never had a problem connecting to these mapped drives.

However, since I moved to this new laptop, every time I start Windows I get this annoying error message that reads "Could not reconnect all network drives." Yet when I go to the Windows Explorer and click on the drive that Windows reported as disconnected, it prompts me for my username and password and then opens fine. I don't understand why this keeps happening. I've performed numerous Windows Updates on the system and checked everything I could possibly think of to correct this, but for some reason I just can't seem to get rid of it. Do you have any idea what could be causing this problem and what steps I need to take in order to fix it?

This isn't an uncommon problem for new users of Windows XP. The solution to your problem is actually quite simple. However, it's going to cost you. Basically the cause of your problem boils down to just one thing — Windows XP Home Edition.

When Windows XP was originally conceived of by Microsoft, one of its primary purposes was to merge Windows 9x and Windows NT into a single operating system. As a result of this unification and (in my opinion) to keep revenues up, Windows XP was broken into a few different flavors: Home Edition, Media Center and Professional. In spite of the fact that all three of these are Windows XP, each contains features that are version-specific. In some cases, that means features have been added. In others cases, features were taken away. This makes it difficult for one version of the operating system to perform a task designed for another.

For example, Windows XP Home Edition can do everything Windows XP Media Center can do. They all play DVDs and MP3 files, can be used to work on school reports, play games, browse the Web and so on. By adding a TV tuner to your Windows XP Home Edition PC, you can even watch and record TV, just like a Media Center PC. The difference between the two is that a Media Center PC combines all of these features into a new user friendly interface (with a remote control) for managing all of these activities, whereas the Home Edition PC requires you to perform each of these task using various other applications installed independently on your system.

In regards to your problem, Windows XP Home Edition was designed to be used at home or, more specifically, in areas where there were no network servers present. Home Edition PCs can share files across a workgroup and even access files stored on a network domain. However, a Windows XP Home Edition PC cannot be a member of a Windows 2000 domain and as such is not given access to all of the network resources.

What's happening now is that when your PC starts it tries to map to a network drive without first being authenticated by the network. Due to this lack of authentication, Windows is incapable of making a successful connection to the drive. Then when you go to Windows Explorer and select one of the drives that couldn't be mapped on startup, the domain prompts you for your network credentials before finally granting you access to the mapped drive.

Unfortunately, the only way for you to correct this issue is to upgrade your system to Windows XP Professional. According to Buy.com, that will cost you more than $200.

The reason you never had this problem with Windows 98 was because back then all versions of Windows had the capability to participate as a member of a domain. When the products were unified, they did away with that. Sorry I couldn't give you better news.

Adapted from PracticallyNetworked

Do you have a comment or question about this article or other small business topics in general? Speak out in the SmallBusinessComputing.com Forums. Join the discussion today!

Comment and Contribute


     

    Get free tips, news and advice on how to make technology work harder for your business.

    Submit
    Learn more
     
    You have successfuly registered to
    Enterprise Apps Daily Newsletter
    Thanks for your registration, follow us on our social networks to keep up-to-date